Math 256
Getting Started with *Mathematica*

Steven Tschantz

1/6/14

**Basics**

The best way (maybe the only way) to learn *Mathematica* is to use it to solve problems. You need to find out how to get *Mathematica* to help you do what you want done rather than be restricted to preprogrammed functions. To get to that point will take a good deal of experimentation, exploration, trial and error. You will have lots of time to explore, and a variety of problems to work on in this course. But it will help to have a few aspects of *Mathematica* simply explained at the outset.

**Files**

*Mathematica* files are called notebooks, since they give you a means of recording and presenting your calculations as you might do in a laboratory notebook. While readable by other programs, notebook files are really only useful when formatted by *Mathematica* (or the read-only version *MathReader* or in a special browser plug-in). Web browsers will sometimes try to show you the text of a *Mathematica* notebook. Instead you will want to save a downloaded notebook to your local computer in some known location and open the file using *Mathematica*, so that you can see the formatted version, make changes, do computations, and save your results.

**Cells and groups of cells**

A *Mathematica* notebook is a vertical list of cells and groups of cells as indicated by cell brackets at the right border. There are different types of cells, for titles, section and subsection headings, ordinary text, calculation input and output, each with a distinctive default style and size of text for ease of recognition. Click on the cell bracket to select a cell as a unit for cutting, copying, or changing the type of a cell. The cell type is selected in the menu Format>Style>. Cell groups denote sections, subsections, etc., and pair calculation input and output. A group of cells can be closed by double-clicking the cell bracket so that only the first cell shows; a closed group can be opened by double-clicking the cell bracket. This allows display of a notebook in outline form. Try closing this subsection and reopening it, being careful which cell bracket you click on.
Insertion point

If you point within a cell, you will see a vertical I-beam pointer. Clicking in a cell positions the insertion point, as indicated by a blinking vertical bar, where what you type will appear. If you point between cells or after the last cell, you will see a horizontal I-beam pointer. Clicking will position the insertion point, a horizontal bar the width of the window, where typing will begin a new cell in the vertical list of cells. The default new cell is an input cell, what you will ordinarily need for doing calculations. The menu Format>Style> allows you to start a cell of another type.

Evaluation

The Mathematica front-end program manages display, editing, opening and saving of notebooks. It has many of the functions of a full featured WYSIWYG editing program with special functions for managing calculations. The Mathematica kernel is a separate process that interprets a specialized programming language for doing sophisticated numerical and symbolic calculations. You communicate with the kernel by typing expressions to be evaluated into an input cell and pressing shift-Enter (or Enter on the numeric keypad). The kernel evaluates the expression in the input cell, and returns any results as an output cell inserted into the notebook after the corresponding input cell, replacing any output that had appeared there. The insertion point is moved to after the output cell so you can start a new input cell simply by typing, evaluating the input when you press shift-Enter, getting another output, etc. The result is like a conversation with the kernel program, automatically recorded as a transcript in your notebook.

The latest version of Mathematica offers possible continuations of partial command and variable names when typing in input cells. It may try to help you by offering a pop-up menu of possible commands to apply to your last output. It uses syntax highlighting, and shows matching grouping symbols. Output is formatted using standard mathematical notation for the most part, and it is possible to use mathematical notation for input (using a palette) though its probably easier to learn and use Mathematica's programming language. It is even possible to use the Wolfram alpha natural language interface to specify your input. All of these options are intended to make it easier to do calculation, but in the beginning they can be a distraction. Concentrate for now on the basic process: type input cell; shift-Enter to evaluate; get output; repeat.

Evaluating examples

You can evaluate any input cell by either positioning the insertion point within the cell, or by selecting the cell itself by clicking on the cell bracket, and then pressing shift-Enter. You can evaluate a whole range of cells by selecting the first cell bracket, shift selecting the last cell bracket, and then pressing shift-Enter. Alternatively, you can evaluate a group of cells by selecting the cell group bracket. In this way you can follow along with examples interspersed with the text, re-executing the calculations to verify the output results, or you may copy and modify the examples for your own calculations.

The cells you evaluate are marked by In[n]:= with corresponding output marked by Out[n]=, in numerical order, but these numerical tags are not saved with your notebook. You can evaluate input cells out of order, but if one step in a calculation depends on a previous result, then such out-of-order evaluation will only lead to confusion. You can edit your notebooks to remove scratch work and unused experiments, but ideally your notebook should include all the steps that you use to calculate a result, so that someone reading your notebook and reevaluating your inputs in the given order will get the same result.
Basic syntax

Here are some basic hints about the Mathematica language. Everything is an expression. An expression is either an atom or a function applied to arguments. Atoms are exact integers or rational numbers, variable precision approximate floating point numbers, symbols given by alphanumeric identifiers (with $ taken as a letter) beginning with a non-numeric character and taking capitalization significant, strings enclosed in double quotes " ", and a few other special forms. A function f applied to arguments x1,x2,...,xn is denoted by f[x1,x2,...,xn]. Parentheses ( ) may be used for grouping but brackets are reserved for function application. Built-in Mathematica functions are given by symbols starting with a capital letter, and are almost always with a standard mathematical name or written out in complete words. Thus E is the Mathematica symbol for the base of the natural log, Sin is the Mathematica name for the sine function, and Solve is the function for solving equations. But there are also a significant number of special short-hand notations for named Mathematica functions. Of course, arithmetic operations +, -, *, /, ^ (for exponentiation) are recognized. A single equal sign = is assignment, a double equal sign == is used for equations, <= becomes ≤ for inequalities. A list is denoted by braces { }, the elements of a list (or arguments in any expression) are accessed by indexing using double brackets [ [ ] ]. A rule is given by an arrow typed as ->, the replace operation may be denoted by /. between an expression and a rule, list of rules, or list of list of rules.

The assignment of a value val to a variable var is given by var = val. To define a function f of a variable x as an expression in x you need to tell Mathematica that the variable x is a dummy variable allowed to take any argument value. The underscore is a special notation for patterns; in a function definition, f[x_] on the left hand side of an assignment defines a pattern with x taking the value of the argument of the function f.

A complete example

Here then is a complete example of Mathematica commands for solving a system of 2 linear equations in 2 variables, one (small) step at a time. Suppose the first equation is

In[1]= eqn1 = 2 x + 3 y == 7

Out[1]= 2 x + 3 y == 7

This input assigns to a symbol eqn1, an expression which is an equation. The single = sign is always assignment in Mathematica; the (condensed) double equal sign is typed as == but becomes a slightly condensed symbol for an equation. The symbols x and y have no values (at the moment) and so are treated as variables. Syntax highlighting shows the x and y in blue to show they have no defined values; eqn1 is shown in black once the assignment has been made (evaluate the input to follow along). The result of the assignment is the equation that has been assigned, a check that you’ve assigned the right thing. Take the second equation to be

In[2]= eqn2 = 5 x - 2 y == 3

Out[2]= 5 x - 2 y == 3

Next we want to solve for the variables. The Mathematica command is Solve. Mathematica defined symbols all start with a capital letter, and capitalization in symbols is significant. Taking first letter lower case symbols for your variables and definitions is thus always safe. If you want to know the syntax of a command you can highlight the command and select Find Selected Function from the Help menu.
The Solve command takes an equation or a list of equations, delimited by braces \{\}, and a variable or list of variables to solve for. The symbol solns has been assigned the result of the Solve command. It consists of a list of one solution, the one solution being a list of rules giving values for each of the variables. A rule does not assign a value to the variable, but can be used to replace values for variables in an expression. Note that these are exact rational number answers. A decimal approximation can be displayed using the N function.

Here are some more steps that might be used to illustrate and verify the solution. The replace operation is denoted by \/. and substitutes each solution (just one) in the expression giving a list of results. Let's back substitute the solution in the original equations.

We can solve for \( y \) in terms of \( x \). Double brackets \[[\]]\) select elements in a list, in this case the first solution is selected.

And we can then plot these two lines, highlighting the intersection point we found.
A second example

Using long names helps document your calculations.

\[\text{annualinterestrate} = 12.\]

\[\text{principal} = 10000\]

\[\text{annualsimpleinterest} = \text{principal} * \text{annualinterestrate} / 100\]

\[\text{annualsimplereturn} = \text{principal} * (1 + \text{annualinterestrate} / 100)\]

\[\text{nperiods} = 4.\]

\[\text{compoundreturn} = \text{principal} * (1 + \text{annualinterestrate} / 100 / \text{nperiods})^{\text{nperiods}}\]

\[\text{compoundinterest} = \text{compoundreturn} - \text{principal}\]

\[\text{effectiveinterestrate} = \text{compoundinterest} / \text{principal} * 100\]

If the interest on an account earning 12% per year with an initial balance of $10000 is paid only at the end of the year (simple interest) then $1200 is earned for a final account balance of $11200. If instead interest is paid quarterly (12%/4=3% interest per quarter) and interest is paid on interest (compounding) then the account ends at $11255.09, the interest earned is $1255.09, $55.09 more than the simple
interest case, effectively equivalent to simple interest of 12.5509% annually.

**Help**

Nearly all of *Mathematica* is documented in the Document Center under the Help menu. There are also a number of Tutorials about *Mathematica* and numerous examples of how to use *Mathematica* available. You have to explore what’s available and how you can use *Mathematica* to solve problems you want to solve.

---

**Exercises**

To get started, as practice with *Mathematica*, complete the following exercises.
1. Compute $1 + 2 \times 3^4 / 5$. What precedence is applied to arithmetic operations?

2. Compute $100!$ (factorial). How many digits are there in this number (please don’t just count)?

3. Compute the exact value of sine of 90 degrees, 60 degrees, 45 degrees, 30 degrees, and 15 degrees. What are these as decimal approximations? (Note that trig functions take arguments in radians, and Pi is the *Mathematica* symbol for $\pi$).

4. Copy and edit the above calculation of effective annual interest rate for interest compounding, changing the calculation from quarterly to daily compounding for 365 periods in a year. Does the effective interest rate depend on the initial principal (except for round-off errors)? (Try the calculation with principal set to an undefined symbol $p$).

5. Use Solve to find the intersection points of the line given by the equation $y - 2x - 2$ with a circle of radius $5$ centered at the origin (what is the equation of this circle?) as illustrated in the following diagram.

```
In[21]:= Plot[2 x - 2, {x, -5, 5}, Epilog -> {Circle[{0, 0}, 5], AspectRatio -> Automatic}]
```
6. Define a function by the polynomial \(x^3 - 6x^2 - 15x + 10\). Plot the function on the interval \(-10 \leq x \leq 10\). Find the local maxima and minima of this function.

First assignment

The first assignment is file 01.3-Assignment01.nb to be completed for Monday Jan. 13. Expect weekly assignments in a similar format. We will discuss further examples and try some experiments in class Wednesday and Friday with some time in class for working on and answering questions about this first assignment.